yilangcode

一、SpringCloud-SpringBoot 对应的版本选择

SpringCloud官网常规方式只能查看最新的几个版本信息

https://spring.io/projects/spring-cloud 

先查看SpringCloud版本对应的SpirngBoot大致对应的版本范围。

 

 

 点击图示的地方,就能够查看对应的具体的SpringBoot版本。

 

 

 这是官方推介的SpringCloud版本对应的SpringBoot版本,一般按照这个版本来搭建项目,很少会出现一些奇奇怪怪的问题。

 

 

还有另外一种方式,通过mavan仓库官网查看对应的SpringCloud版本,地址如下

https://mvnrepository.com/artifact/org.springframework.cloud/spring-cloud-dependencies?__cf_chl_captcha_tk__=pmd_zdicnYi0M9UvWxkdQRhHE28J59L70NrgPC_9uiSfeSA-1635063954-0-gqNtZGzNA5CjcnBszQo9 

会发现其对应的具体版本非常多,

 

 

 如果通过具体的SpringCloud版本去查找对应的SpringBoot版本呢?

有个简便方法,就是直接在地址栏中修改对应的版本信息。

以为自己选择的springcloud版本为 Hoxton.SR4  从官网上上面找到对应的版本详情地址,比如 https://cloud.spring.io/spring-cloud-static/Hoxton.SR4/reference/htmlsingle/

直接修改版本信息即可,如将Hoxton.SR4修改Hoxton.SR6即可进行查看。

上面这种方法还是有很多的版本无法找到,就可以参考这篇文章https://www.cnblogs.com/lixingwu/p/14889716.html

我们可以到 Spring Cloud 官网找到对应的说明:

https://docs.spring.io/spring-cloud/docs

以下图点击的版本为例,进行操作

 

 

 然后点击下图所示的地方.

 

 

 最后点击这个位置就可以查看具体的SpringBoot版本信息

 

 

 

 

 

至此查找SpringCloud对应的SpringBoot版本完成。

参考文章:https://blog.csdn.net/haiertadiedie/article/details/109773036


二、SpringCloud--SpringCloudAlibaba 对应的版本选择

现在SpringCloudAlibaba非常火,自己开发中也在正常使用,可是如果其与SpringCloud对应的版本呢。

去到SpringCloudAlibaba官网,git地址如下,

https://github.com/alibaba/spring-cloud-alibaba/wiki/

点击版本说明即可查看,

 

具体的版本说明参考官网,下图为说明截图,

 

 阿里官方推介使用毕业版本。

 

 

 在官网上面如何引入依赖都有详细的说明,多去看看,了解一下就能够学会。

至此版本选择全部说明完毕,可根据自己项目的需要来选择对应的版本。版本选择有一点,一般都选择发布版,这是常识,发布版更加的稳定,

也就是RELEASE 版本。并且现在主流的SpringBoot版本,大多已经开始使用SpringBoot 2.X的版本,需要自己慎重选择版本进行开发,有得选的话

尽量避免选择SpringBoot 2.x一下的版本,因为Spring官方对于很多低版本的框架已经停止维护,所以选择要慎重。

 

这是本人选择版本:

<!-- 依赖的jar包所对应的版本 -->
<properties>
<spring-cloud.version>Hoxton.SR3</spring-cloud.version>
<spring-cloud-alibaba.version>2.2.1.RELEASE</spring-cloud-alibaba.version>
<spring-cloud-starter-alibaba-nacos-config.version>1.2.1</spring-cloud-starter-alibaba-nacos-config.version>
<spring-boot-admin.version>2.3.0</spring-boot-admin.version>
</properties>
<dependencyManagement>
<!-- springcloud版本 -->
<dependency>
<groupId>org.springframework.cloud</groupId>
<artifactId>spring-cloud-dependencies</artifactId>
<version>${spring-cloud.version}</version>
<type>pom</type>
<scope>import</scope>
</dependency>

<!-- springcloud alibaba 版本 -->
<dependency>
<groupId>com.alibaba.cloud</groupId>
<artifactId>spring-cloud-alibaba-dependencies</artifactId>
<version>${spring-cloud-alibaba.version}</version>
<type>pom</type>
<scope>import</scope>
</dependency>
<!-- spring-boot-服务监控服务端 -->
<dependency>
<groupId>de.codecentric</groupId>
<artifactId>spring-boot-admin-starter-server</artifactId>
<version>${spring-boot-admin.version}</version>
</dependency>
<dependencyManagement/>

相关文章:

猜你喜欢