首先按照 http://www.cnblogs.com/toSeek/articles/3011455.html 让opensuse12.1可以使用after.local,然后在此文件中加入了/root/tomcat/bin/startup.sh,却死活启动不了。

systemctl start 会提示:

Job failed. See system logs and 'systemctl status' for details.

后来查到如果不登陆系统,/etc/profile文件是不会被加载的,由于java环境变量都配到了此文件,于是就启动不了,解决方法是在启动tomcat语句的上面加上:

source /etc/profile

 

本文最早写在51cto上:http://mayacong.blog.51cto.com/blog/3724695/994939

相关文章:

  • 2022-12-23
  • 2021-08-03
  • 2022-12-23
  • 2022-01-30
  • 2022-12-23
  • 2021-07-13
  • 2021-04-30
  • 2021-11-05
猜你喜欢
  • 2021-07-28
  • 2022-12-23
  • 2022-12-23
  • 2021-05-29
  • 2021-12-06
  • 2021-10-19
  • 2021-09-25
相关资源
相似解决方案