【问题标题】:Azure LogAnalytics query for disabled Traffic Manager ProfileAzure LogAnalytics 查询禁用的流量管理器配置文件
【发布时间】:2019-05-17 11:36:36
【问题描述】:

我希望从 Log Analytics 中查询 Azure Network/"trafficManagerProfiles 事件,更具体地说,当流量管理器配置文件处于禁用状态时。

我设法找到了一个特定事件,发现我需要查看嵌套在“Prorperties”->“requestbody”->“properties”->“profileStatus”中的“profileStatus”。检查图像@987654321 @

AzureActivity | where ResourceId contains "trafficManagerProfiles" | where Properties contains 'profileStatus'

当流量管理器配置文件时,更具体地说,当“profileStatus”等于“禁用”时,我需要在 LA 中获取事件

【问题讨论】:

    标签: azure-log-analytics azure-traffic-manager nested-table


    【解决方案1】:

    在这篇文章中找到答案:Log Analtyics - How to use "inverted commas" within search query

    AzureActivity | where ResourceId contains "trafficManagerProfiles" | where Properties contains '\\"profileStatus\\":\\"Disabled\\"'

    【讨论】:

      猜你喜欢
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 1970-01-01
      • 2016-02-05
      • 1970-01-01
      相关资源
      最近更新 更多