deverz

composer 属于php的包依赖管理工具。

1、进入Composer国内镜像网站文档页查看安装方法:

https://docs.phpcomposer.com/00-intro.html

2、在centOS系统中进入特定目录执行以下命令:

cd /usr/local/composer
curl -sS https://getcomposer.org/installer | php

注意:该步骤可能遇到以下问题:

2.1、openssl扩展:

Some settings on your machine make Composer unable to work properly.
Make sure that you fix the issues listed below and run this script again:

The openssl extension is missing, which means that secure HTTPS transfers are impossible.
If possible you should enable it or recompile php with --with-openssl

遇到以下问题为php没有开启或安装 openssl 扩展导致

首先php -m 查看以下扩展加载内容。

没有安装则编译安装openssl扩(以下为源码包安装方式):

1、cd /down/php-7.2.9/ext/openssl/
2、/usr/local/php/bin/phpize
3、./configure --with-openssl --with-php-config=/usr/local/php/bin/php-config 
4make
5make install

php-config路径注意根据自己的路径修改

之后打开php.ini文件将openssl扩展开启即可,没有就添加:

vim /usr/local/php/lib/php.ini
添加:
extension=openssl

此时再次执行php -m就可看到openssl扩展已经启用。

 

2.2、zip扩展

执行安装composer时可能会提示没有安装zip扩展可能会导致composer执行缓慢之类的提示,安装zip扩展即可

安装方法和openssl扩展相似,最后修改php.ini文件

zlib.output_compression = On
extension=zip

之后应该就没有什么问题了。

 

3、将composer加到/usr/local/bin中,避免执行 php composer.phar

mv composer.phar /usr/local/bin/composer

如果执行composer时报错:
出错: /usr/bin/env: php: 没有那个文件或目录

就添加一个软链接即可:
ln -s /usr/local/php/bin/php  /usr/local/bin/php

 

 4、多个版本php时,可以指定php版本执行composer

/usr/local/php72/bin/php composer.phar

 

分类:

技术点:

相关文章:

猜你喜欢